Difference between revisions of "Z80 ERROR"

From NeoGeo Development Wiki
Jump to: navigation, search
(Created page with "A generic error that occurs when the 68k doesn't receive a response from the Z80 when required. Command byte $01 is sent to the Z80 when its program ROM needs to be changed, suc...")
 
(MV1C: Replaced with MV1B which matches the next sentence)
 
(7 intermediate revisions by one other user not shown)
Line 1: Line 1:
A generic error that occurs when the 68k doesn't receive a response from the Z80 when required. Command byte $01 is sent to the Z80 when its program ROM needs to be changed, such as power-on ([[SM1]] to cart [[M1 ROM]]) or when switching the active slot (changing which cart M1 ROM is selected). This command mutes [[YM2610]] audio and jumps to an infinite loop in RAM where it is then safe to switch the Z80 program ROM.  The Z80 sends the 68k $01 right before jumping to signal that it is safe to switch.  If the $01 byte is never received, "Z80 ERROR" is displayed on screen.
+
[[File:error_z80.png|thumb|Simple as that.]]
  
==Testing==
+
=Causes=
  
The Z80 doesn't test the SM1, its RAM or the YM2610.  This error only covers bad [[68k/Z80 communication]], but if any of those components are bad, it can stop the Z80 from being able to reply which will then cause the error to be displayed.
+
The {{Chipname|68k}} didn't receive a reply to command $01 from the {{Chipname|Z80}} in time. The Z80 doesn't test the [[SM1]] ROM, its [[Z80 RAM|RAM]] nor the {{Chipname|YM2610}} but if any of those components are bad, they can prevent the Z80 from being able to reply which will then cause the error.
  
==MV-1C==
+
=Repair suggestions=
  
This board displays this error with no cart inserted since it has no SM1 to control the Z80.
+
On [[MV1F]] boards, this error seems common due to trace cuts caused by a [[corrosion|leaking battery]]. A few [[trace patching|wires]] can solve the problem.
 +
 
 +
* Check Z80 +5V supply, reset and [[clock]] signals
 +
* Check connectivity to Z80 work RAM
 +
* Check connectivity to SM1 ROM or cartridge's M1 ROM
 +
* Check {{Chipname|NEO-D0}} Z80 control lines
 +
* Check Z80 data bus at {{Chipname|NEO-C1}}
 +
* ...
 +
 
 +
Note: Replacement SMT Z80s can be found in some Ti calculators :)
 +
 
 +
=MV1B=
 +
 
 +
The {{PCB|MV1B}} board displays this error when no cart inserted because it has no SM1 ROM. '''This is normal'''.
 +
 
 +
[[Category:Audio system]]
 +
[[Category:Repairs]]

Latest revision as of 00:40, 1 June 2021

Simple as that.

Causes

The 68k didn't receive a reply to command $01 from the Z80 in time. The Z80 doesn't test the SM1 ROM, its RAM nor the YM2610 but if any of those components are bad, they can prevent the Z80 from being able to reply which will then cause the error.

Repair suggestions

On MV1F boards, this error seems common due to trace cuts caused by a leaking battery. A few wires can solve the problem.

  • Check Z80 +5V supply, reset and clock signals
  • Check connectivity to Z80 work RAM
  • Check connectivity to SM1 ROM or cartridge's M1 ROM
  • Check NEO-D0 Z80 control lines
  • Check Z80 data bus at NEO-C1
  • ...

Note: Replacement SMT Z80s can be found in some Ti calculators :)

MV1B

The MV1B board displays this error when no cart inserted because it has no SM1 ROM. This is normal.